Cannot load Zend Extension Manager – it was built with configuration 1.2.0, whereas running engine is API220090626,NTS

After upgrading to PHP 5.3.x I’m receiving an error

1
2
3
4
5
$ php -v
Cannot load Zend Extension Manager
    - it was built with configuration 1.2.0,
    whereas running engine is API220090626,NTS
   ...

This is because you have Zend Optimizer installed which only works with PHP up to 5.2.x. You’ll want to comment out the Zend Optimizer configuration in your php.ini and then look into Zend Guard if you still need to work with “Zend Binary” code. Of course this presents another problem as scripts compiled with Zend Optimizer won’t work with Zend Guard. If you’re using third party “optimized” scripts and there is no Zend Guard version available or you want to continue to use Optimizer for other reasons you’ll probably want to move back to PHP 5.2.x.

Disabling Zend Optimizer

For me that meant commenting out the following lines in my php.ini

1
2
3
4
5
6
[Zend]
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.9
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.9
zend_optimizer.version=3.3.9
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
Category(s): languages, PHP, Server Administration, Web Servers
Tags: , , , , , ,

Leave a Reply

Your email address will not be published. Required fields are marked *

*

 

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Spam protection by WP Captcha-Free